Subject Re: [firebird-support] Linux versions supported?
Author Paul Reeves
On Monday 14 July 2003 09:34, Helen Borrie wrote:

> I've had no success clean-installing SuSE 8 Pro on either of my Linux
> machines. As SuSE is the ultimate non-free, non-cheap Linux, I won't be
> able to see where I'd go with SuSE 9 (unless someone wants to give me a
> late birthday present). Nickolay said he has Kylix 3 AND RC3 superserver
> running on a SuSE 9.1 box. (There is no RC4 Superserver yet.)

Amid the proliferation of distros and version numbers I should point out that
Nickolay uses Mandrake 9.1. There is not yet a SuSE 9.1. The latest version
of SuSE is 8.2.

> The FB/Linux version incompatibilities are due to the high versions of
> GLIBC which have been used to compile the more recent Fb 1.5 binaries (or,
> rather, to build the libc++ runtime that Firebird links to). I think it's
> a showstopper but none of the Firebird devs thinks so, so who am I to
> argue? The problem from their POV is that the Linux C++ compiler support
> prior to GLIBC_2_3 is unstable.

The compiler issue is actually separate from glibc. It just happens that the
compiler required (gcc 3.3) is only available on distros that ship with glibc
2.3. So building Firebird in that environment introduces an unnecessary
dependancy. In theory it is possible to compile/install the 3.3 compiler on
distros with earlier versions of glibc and it is possible to link Firebird
against earlier versions of glibc, even if building on a box with glibc 2.3.

I've gone down the build/install gcc from scratch route before and have never
been happy with the outcome. Personally, I would just install a new distro
for development purposes, rather than build the compiler on an older distro.
It is the line of least resistance in my case.

It ought to be possible to link against earlier versions of glibc and
libstdc++ (another of the wild cards in this game) but the current build
process is just using the latest found at compile time.

All in all, this is just a way of waying that if gcc 3.3 is required and that
then requires glibc 2.3 then that is the way things are. I'm beginning to
accept it, albeit reluctantly.

> The Kylix incompatibilities seem to involve a variety of X-related
> packages. We can probably only depend on the Linux versions that Borland
> certified, per Kylix version. This isn't going to change soon, since I've
> read that Kylix development is completely shelved at present while the
> developers play with their .NETballs.

Again, speaking personally, it looks like Kylix is becoming a dead end. At
least Firebird is under continuous development, so the pain of upgrading to a
distro that supports it will be worthwhile.

> It's not realistic for me to keep doing
> this: I need a CD distro that "just works".

Don't you have computer mags with Linux distros on them? I usually see
Mandrake and RedHat on the news stands locally about twice a year, for the
price of a few euros. ( I foolishly turned down the opportunity to get
Mandrake 9.1 like this a couple of weeks ago - and now it is gone from the
news stands. Bah!)

Paul Reeves
Supporting users of Firebird and InterBase