Subject Re: [Firebird-Architect] RFC: Proposal for the implementation
Author Jim Starkey
Dmitry Yemanov wrote:

>"Martijn Tonies" <m.tonies@...> wrote:
>>Perhaps it SHOULD be RELATION_TYPE -> after all, a view is a relation.
>>Why is "storage type" so important? Isn't that dependent of the relation
>>type? (base table, view, temp etc)
>It was proposed by Ann that we need an extra column to distinguish between
>regular and temporary tables. It seems that RDB$FLAGS is not appropriate for
>this purpose. RDB$RELATION_TYPE was suggested and some guys opposed that
>views are also relations and hence this name is not very accurate (someone
>may think that this column distinguishes between tables and views). As a
>result, I propose RDB$STORAGE_TYPE here. If somebody has better ideas, I'm
>all ears. We just need to choose one and stick to it.
I don't see what's wrong with RDB$FLAGS? All you need is a bit that
says it's a temporary table.


Jim Starkey
Netfrastructure, Inc.
978 526-1376