Subject Re: [firebird-support] JayBird and Wavemaker
Author Mark Rotteveel
On 14-1-2013 09:58, zilez2003 wrote:
> Long time I wasn't here, so I am not sure is this correct group to post to. I have Firebird 2.5.1 on my Win7 64 bit OS, and I downloaded Wavemaker 6.5.2. Java Version is 7 (subrelease 10). I can't make Wavemaker to work with Firebird. I have copied folowing jar files from Jaybird-2.2.1JDK_1.7:

The Firebird-Java mailinglist would be a better list for questions
regarding Jaybird.

> antlr-runtime-3.4
> connector-api-1.5
> jaybird-2.2.1
> jaybird-2.2.1-sources
> jaybird-full-2.2.1
> log4j-core

The absolute minimum for Jaybird to run is *either* jaybird-2.2.1 and
connactor-api-1.5 (which is only needed if the application server itself
doesn't already provide the connector-api) *or* jaybird-full-2.2.1
(which includes the classes from connector-api). To be able to use the
generated keys retrieval you also need antlr-runtime-3.4 (advisable to

You never need jaybird-2.2.1-sources, except maybe inside the IDE if you
want to look at the code. log4j-core is only needed when you want to use
the logging provided by Jaybird.

> Files are copied into folder:
> C:\Program Files (x86)\WaveMaker\6.5.2.Release\studio\WEB-INF\lib.
> Also to the lib folder of my project.
> The error I am getting is:
> Connection failed: UnsupportedClassVersionError: org/firebirdsql/jdbc/FBDriver : Unsupported major.minor version 51.0 (unable to load class org.firebirdsql.jdbc.FBDriver)
> Can someone help, or give me the hint where to ask, if this is not appropiate group.

This error indicates that you are not using Java 7, but more likely
running under Java 6 (or maybe Java 5). Version 51.0 is the version of
the bytecode for Java classes compiled for Java 7, so if you get this
error it means that you are running a lower Java version.

Looking at the Wavemaker documentation, the Windows version includes a
private JVM (most likely Java 6). So to fix the error, use the Jaybird
version for Java 6 (JDK1.6).

Mark Rotteveel