Subject Re: [Firebird-Architect] RFC: Proposal for the implementation
Author Vlad Horsun
> >It was proposed by Ann that we need an extra column to distinguish between
> >regular and temporary tables. It seems that RDB$FLAGS is not appropriate for
> >this purpose. RDB$RELATION_TYPE was suggested and some guys opposed that
> >views are also relations and hence this name is not very accurate (someone
> >may think that this column distinguishes between tables and views). As a
> >result, I propose RDB$STORAGE_TYPE here. If somebody has better ideas, I'm
> >all ears. We just need to choose one and stick to it.
> >
> >
> >
> I don't see what's wrong with RDB$FLAGS? All you need is a bit that
> says it's a temporary table.

I don't understand needs in RDB$RELATION_TYPE, too