Subject Re: [Firebird-Architect] RFC: Proposal for the implementation
Author Dmitry Yemanov
"Martijn Tonies" <m.tonies@...> wrote:
> Perhaps it SHOULD be RELATION_TYPE -> after all, a view is a relation.
> Why is "storage type" so important? Isn't that dependent of the relation
> type? (base table, view, temp etc)

It was proposed by Ann that we need an extra column to distinguish between
regular and temporary tables. It seems that RDB$FLAGS is not appropriate for
this purpose. RDB$RELATION_TYPE was suggested and some guys opposed that
views are also relations and hence this name is not very accurate (someone
may think that this column distinguishes between tables and views). As a
result, I propose RDB$STORAGE_TYPE here. If somebody has better ideas, I'm
all ears. We just need to choose one and stick to it.

I also suggest to separate this discussion into a few parts. First - GTT
semantics. Seems like we all in agreement here. Second - storage design and
implementation. Third - per attachment visibility. Both are covered in my
weekend message. Once 1, 2 and 3 are agreed on, GTT can be implemented.
Fourth - LTT (both created and declared) semantics. Fifth - LTT
implementation (mainly metadata visibility issue). Sixth - <as subquery>
design and implementation.

Did I miss anything?